Bize Ulaşın / Contact Us

VMware Logo

VMWare vCenter Server 5.5 installation on Windows 2012 R2 stuck at Directory Services Installation

27 / 11 / 2013 by vCenter 1 Yorum / Comment

I have just experienced the problem below while testing VMware vCenter 5.5 on Windows 2012 R2. It stuck at Installing Directory Services step.


I found the installer was trying to run a non-existing file “ocsetup.exe” at this step, weird thing is vCenter installer doesn’t complain about that, it only waits, the log file is under %temp%\vminst.log.

  1. VMware VirtualCenter-build-1235232: 11/27/13 09:48:55 Begin Logging
  2. VMware VirtualCenter-build-1235232: 11/27/13 09:48:55 — CA exec: VMAdamInstall
  3. VMware VirtualCenter-build-1235232: 11/27/13 09:48:55 Getting Property CustomActionData = 603;603;C:\Users\ADMINI~1.VML\AppData\Local\Temp\{A4400513-2688-45A9-8439-CA991F4E4106};C:\Windows\SysWOW64\;C:\Windows\system32\;C:\Windows\ADAM\
  4. VMware VirtualCenter-build-1235232: 11/27/13 09:48:55 setupApp = [C:\Windows\system32\ocsetup.exe]
  5. VMware VirtualCenter-build-1235232: 11/27/13 09:48:55 — function: SetupComponentOnWindows
  6. VMware VirtualCenter-build-1235232: 11/27/13 09:48:55 [C:\Windows\system32\cmd.exe /c start /w C:\Windows\system32\ocsetup.exe DirectoryServices-ADAM /passive /norestart]
  7. VMware VirtualCenter-build-1235232: 11/27/13 09:48:55 Util_Launch::Wait: 1 Hide: 1
  8. VMware VirtualCenter-build-1235232: 11/27/13 09:48:55 Found “C:\Windows\system32\cmd.exe”
  9. VMware VirtualCenter-build-1235232: 11/27/13 09:48:55 Attempting to launch [“C:\Windows\system32\cmd.exe” /c start /w C:\Windows\system32\ocsetup.exe DirectoryServices-ADAM /passive /norestart]

I copied ocsetup.exe file from a Windows Server 2008 R2 server’s system32 to C:\Windows\system32 folder on Windows Server 2012 R2.

  1. VMware VirtualCenter-build-1235232: 11/27/13 10:40:44 Attempting to launch [“C:\Windows\system32\cmd.exe” /c start /w C:\Windows\system32\ocsetup.exe DirectoryServices-ADAM /passive /norestart]
  2. VMware VirtualCenter-build-1235232: 11/27/13 10:41:11 Process returned 0

Hope it helps.

 

 

 

One comment on “VMWare vCenter Server 5.5 installation on Windows 2012 R2 stuck at Directory Services Installation

  1. on September 1, 2014
    Bertrand Das says:

    Many thanks guy, your rox!
    Your explain as solved my problem!

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">

*

Kontrol / Control * Time limit is exhausted. Please reload CAPTCHA.